Back to overview
Degraded

Account Dashboard and payment systems unavailable for some users

Aug 14 at 12:20am BST
Affected services
Account Dashboard
Advanced Bookings
Bills
Mobile App

Resolved
Aug 14 at 08:39am BST

We’ve been investigating an issue with our Account Dashboard and payment systems, that has impacting some users over the last few hours.

Everything is now up and running, and back to normal. We’re working to identify the cause of the issue, so we can prevent any future occurrences.

Created
Aug 14 at 12:20am BST

The Account Dashboard and payment system are unavailable for some users.